Cisco Packet Tracer 6.3 on Fedora 24

Hello everybody,

The cisco packettracer 6.3 is available for GNU/Linux under the next requirements:

  • x86 libraries.
  • nss and ssl libraries.
  • QT4 script-tools, WebKit  and QT3 backward support.
  • (Optional ) Cisco NetSpace account.

We need install x86 libraries (32 bits) if our system is x86_64 (64bits) as follows:

$ sudo dnf install zlib-devel.i686 ncurses-devel.i686 gtk2.i686 glibc.i686 glibc-devel.i686 \\
 libstdc++.i686 libX11-devel.i686 libXrender.i686 libXrandr.i686 libusb.i686 libXtst.i686 nss.i686 \\
 qt.i686 qtwebkit.i686
$ wget  http://www.deltaeridani.com/openssl-lib-compat-1.0.0i-1.fc24.i686.rpm
$ sudo rpm -Uvh openssl-lib-compat-1.0.0i-1.fc24.i686.rpm

Cisco Packet Tracer 6.3 will be downloaded from Cisco Networking Academy Portal or in another places on internet, only ask to google for “PacketTracer63_linux.tar.gz”,

$ tar -xzf PacketTracer63_linux.tar.gz && cd PacketTracer63
$ chmod +x install
$ sudo ./install

After accept the EULA, the installation begins, we need set the environment variables with the next command:

$ sudo /opt/pt/set_ptenv.sh

At this point packettracer is ready to use but another useful thing to do is create a desktop Cisco Packet Tracer icon to launch it, first download the icon:

$ wget http://upload.wikimedia.org/wikipedia/en/d/dc/Cisco_Packet_Tracer_Icon.png
$ sudo mv Cisco_Packet_Tracer_Icon.png /usr/share/icons/

With our favorite plain text editor we will create the file /usr/share/applications/packettracer.desktop as follows:

[Desktop Entry]
Encoding=UTF-8
Name= PacketTracer 6.3
Comment=Networking Cisco
GenericName=Cisco PacketTracer 6
Type=Application
Exec=/opt/pt/packettracer
Icon=/usr/share/icons/Cisco_Packet_Tracer_Icon.png
Categories=Education;
StartupNotify=true

Now we will run Cisco Packet Tracer 6.3 from our Desktop:

Screenshot from 2016-07-07 10-15-24Screenshot from 2016-07-07 10-21-57

 

4 comments

  1. gracias por tu ayuda, me la pase dos días tratando de instalar la versión 7 pero nunca me funcionó tuve que descargar la versión 6.3

    yo me he salteado esta parte $ sudo /opt/pt/set_ptenv.sh porque cuando hice eso me salia error que no podía encontrar la ruta, así que seguí con lo que recomendaba la instalación solo le di enter para que creara el enlace simbólico y de alli solo crear el packettracer.desktop con un .png que tu pusiste para enlazarlo. gracias y saludos desde Lima – Perú

    1. No y gracias a ti, me habia quedado en que la 6.3 ara la ultima versión, en breve probare la instalación de la versión 7, esperando tenerla lista si quieres actualizar.

Leave a Reply

Your email address will not be published. Required fields are marked *